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TDK SensEI edgeRX Dashboard V2 

User Guide
Version 3 (V3) – 02 April 2026 

Note: This guide covers the dashboard workflows. Physical installation steps and hardware 
specifications are intentionally excluded and should be referenced from the respective 
hardware datasheets and user guides. 
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1. Introduction

1.1 About This Guide
TDK SensEI's edgeRX end-to-end platform is a complete solution for real-time equipment 
health monitoring. The edgeRX solution leverages edge AI to process data locally at the source 
for faster, more accurate, and more efficient insights. EdgeRX is a user-friendly, low-
maintenance solution that optimizes the collection, analysis, and management of machine 
health data. By continuously monitoring the health status of critical assets, edgeRX reduces 
unexpected downtime, optimizes maintenance to improve efficiency and effectiveness, and 
enables predictive maintenance for users. 

This guide provides a comprehensive step-by-step approach to using the edgeRX Dashboard 
for monitoring machine performance. By leveraging real-time data visualization on the 
dashboard, factory operators can proactively address maintenance needs, reducing downtime 
and operational costs. 

1.2 Related Documentation 
For hardware setup, installation, and physical device troubleshooting, please refer to the 
following user manuals: 

Document Model Number Contents 

edgeRX Gateway 
User Manual SE5100204G-01 Gateway hardware setup, power connection, network 

configuration, LED indicators, physical troubleshooting 

edgeRX Lynq 
Sensor User Manual SE1111101G-01 Sensor hardware activation, physical installation, battery 

information, LED indicators, physical troubleshooting 

These documents can be obtained from your local TDK SensEI representative. 
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2. Getting Started

2.1 Logging into Your Account
Follow these steps to log into your account: 

2.1.1 First-Time Login (New Users) 
1. Open the welcome email received from the tdksensei.com domain.
2. Click the login link to access the edgeRX Dashboard.
3. Create your password during the first login.
4. Complete the MFA setup process (see Section 2.1.2).

Figure 1: Create Password Page 
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2.1.2 MFA / Authenticator Setup 
Multi-Factor Authentication (MFA) adds an extra layer of security to your account. 

1. After entering your credentials, you will be prompted to set up MFA.
2. Download an authenticator app on your mobile device (e.g., Google Authenticator,

Microsoft Authenticator).
3. Scan the QR code displayed on screen using your authenticator app.

Figure 2: MFA Setup Page 

4. Enter the 6-digit verification code generated by your authenticator app.
5. Click "Verify" to complete the setup.
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Figure 3: Authentication Code Entry 

⚠️ Trust This Device: You may select the "Trust This Device" checkbox to bypass MFA for 
30 days on that specific device. 

2.1.3 Existing Users 
1. Navigate to the edgeRX Dashboard login page.
2. Enter your registered email address and password.
3. Enter the 6-digit code from your authenticator app (if MFA is enabled and device is not

trusted).
4. Click "Login" to access the Dashboard.

Figure 4: Login Page 
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2.1.4 Forgot Password 
If you have forgotten your password: 

 
Figure 5: Forgot Password Highlighted 

1. Click the "Forgot Password" link on the login page. 
2. Enter your registered email address. 
3. Click "Submit" to receive a password reset link via email. 
4. Open the email and click the reset link. 
5. Enter and confirm your new password. 
6. Click "Reset Password" to complete the process. 
7. Return to the login page and sign in with your new credentials. 

 

 
Figure 6: Password Reset Flow 
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2.1.5 Profile Settings 
Users can manage their personal account settings by clicking the user icon located at the 
bottom-left corner and navigating to "Profile Settings". 

Figure 7: Profile Page 

From here, users can: 

• Edit personal profile details – Update your name and contact information.
• Change password – Update your account password.
• Manage trusted devices – View and remove devices that have been trusted for MFA

bypass.
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2.2 Navigating the Homepage Dashboard 
After logging in, you will be directed to the Homepage Dashboard. Here you'll see an overview 
of real-time information: 

 
Figure 8: Dashboard Homepage 

Widget Description 

Alarms Active alarms across connected assets 

Warnings Active warnings across connected assets 

Sensor Connectivity Sensor connection health 

Gateway Connectivity Gateway connection health 

Trend Analysis Chart High-level metrics showing asset behaviour over time 
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2.2.1 Location / Facility Selector 
Use the location/facility selector dropdown to switch between different sites or facilities 
within your organization. 

⚠️ Note: Access to this dropdown is restricted to Admin and Global Executive users only. 

2.2.2 Trend Analysis Chart 
The Trend Analysis chart analyses historical trends of notifications using a line chart. Features 
include: 

• Custom date range picker
• Time adjustment slider

2.2.3 Language Selector 
The Global Language Selector is located in the top right corner of the dashboard screen. Users 
can switch between the following languages: 

• English (default)
• Japanese
• Simplified Chinese

The selected language persists across all pages of the application. 

2.2.4 Theme Toggle 
The theme toggle is located in the top right corner of the screen. Users can switch between: 

• Light theme
• Dark theme

The selected theme persists across all pages of the application. 

⚠️ Troubleshooting: If any widget appears inactive or blank, confirm that your gateways and 
sensors are online. 
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3. Managing Users & Permissions
The Administrator ("Admin") can create separate roles and assign specific permissions based 
on the organization's requirements. The TDK SensEI team will set up an organization account 
on the edgeRX Dashboard and grant access to a designated Administrator user. 

3.1 Manage Users 
Navigate to Settings > Manage Users to access user management functions. 

Figure 9: Manage Users 

3.1.1 Viewing the User List 
The user list displays all users within your organization. You can: 

• View all registered users
• Filter users by Department using the dropdown in the top left corner
• Search for users using the search bar by username or email ID
• Adjust the number of rows displayed per page using the "Rows per Page" dropdown

3.1.2 Adding a New User 
To add a new user: 

1. Click the "Add" button on the top right corner.
2. Enter the following details in the modal:
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Figure 10: Add User Modal 

Field Description 

User Name Full name of the user 

Email User's email address (used for login) 

Role Select from existing roles dropdown 

Location Select from existing locations dropdown 

Department Select from existing departments dropdown 

3. Click "Add User" to create the new user account.
4. Click "Cancel" to terminate the action without adding the user.

⚠️ Note: The new user will receive a welcome email with instructions to set up their 
password and MFA. 
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3.1.3 Managing Existing Users 
For each user in the list, you can perform the following actions: 

Action Description When to Use 

Edit User Details Update user information including email 
address 

User changes role, department, or 
email 

Assign Roles Change the user's role and permissions User responsibilities change 

Resend Welcome 
Email 

Send a new welcome email to inactive 
users User hasn't completed initial setup 

Reset Password Force password reset for active users User forgot password or security 
concern 

Resend Verification 
Email 

Send verification email after email 
address update User's email address was updated 

Reset MFA Clear MFA setup for a user User lost access to authenticator 
app 

Figure 11: Members List 

To perform any of these actions, click the corresponding icon or button in the Actions column 
next to the user's name. 
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3.2 Manage Roles 
Navigate to Settings > Manage Roles to create or edit roles and assign module-level access. 

Figure 12: Manage Roles 

3.2.1 Adding a New Role 
To add a new role: 

1. Click the "Add" button.
2. Enter the role name in the field.
3. Click "Create" to add the new role.
4. Click "Cancel" to terminate the action.

Figure 13: Add Role Viewer 
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3.2.2 Configuring Role Permissions 
Use the toggle buttons and checkboxes to enable or disable permissions for each role: 

• Toggle buttons control module access (e.g., Sensors, Gateways, Assets,
Notifications)

• Checkboxes control specific actions within modules (e.g., View, Add, Edit, Delete)

Figure 14: Role Permissions 

Click "Save" to apply permission changes across all users assigned to that role. 

3.3 Global Executive Role 
The Global Executive role provides special privileges: 

• Read-only access to every location in the organization
• Ability to switch between locations using the location selector
• View all dashboards and data including:

• Sensors
• Gateways
• Notifications
• Insights
• Home KPIs

Data displayed is based on the currently selected location. 

⚠️ Note: Global Executives cannot modify data or settings, only view them. 
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3.4 Profile Settings 
Every user has access to their own account management options via Profile Settings. For 
detailed instructions, see Section 2.1.5. 

3.5 Adding a Department 
To add a new department: 

1. Click the Department dropdown.
2. Enter the department name in the field.
3. Click "+" to create the new department.

Figure 15: Adding a Department 
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4. Gateway Management

4.1 Adding a Gateway to the Dashboard
⚠️ Note: Before we can add a gateway, we must set up a location, refer to 11.1 Location 
Hierarchy to set up a location. 

Log into the edgeRX Dashboard using your authorised credentials, then navigate to Gateway 
Summary page. 

Figure 16: Gateway Summary 

Steps to Add a Gateway 

1. Navigate to Gateway > Add Gateway.

Figure 17: Add Gateway Modal 

2. Enter the required details:
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Field Description 

Gateway Name A custom name for identification 

Gateway ID The 12-character Gateway ID (found on the Gateway's box or on the 
flat-bottom surface of the Gateway) 

Location Select the location of the Gateway on the floorplan 

Figure 18: Add Gateway Details 

3. Plot the coordinates on the map component.
4. Click "Save" to register the Gateway into the system.

The new Gateway will appear in the table and be available for monitoring and management. 

⚠️ Note: Ensure that your edgeRX Gateway is online and connected using the Detail tab. If 
your edgeRX Gateway appears offline, see Section 12 for troubleshooting steps. For physical 
sensor installation instructions, refer to the edgeRX Gateway User Manual. 
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4.2 Managing Gateways 

4.2.1 Reboot a Gateway 
1. Click the "Reboot" button.
2. Click "Confirm" to reboot the Gateway.
3. Clicking "Cancel" will terminate the reboot action.

⚠️ Note: Users can only reboot one Gateway at a time. 

4.2.2 Delete a Gateway 
1. Click the "Delete" icon.
2. Click "Delete" to remove the Gateway.
3. Clicking "Cancel" will terminate the delete action.

4.2.3 Edit a Gateway 
1. Click the "Edit" button from the actions column.
2. Update the Gateway ID, Name, and/or Location fields.
3. Click "Save" to ensure your changes are saved.
4. Clicking "Cancel" will terminate the edit action.

4.3 Gateway Table Features 
The table provides a searchable, paginated view of all Gateway devices. 

Feature Description 

Search Bar Locate Gateways by Name, Gateway ID, or Version 

Rows per Page Adjust the number of rows displayed (dropdown in bottom right corner) 

Column Settings Customize visible columns (Settings icon on top right corner) 

Figure 19: Gateway Table 
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4.4 Gateway Detail View 
To access detailed information about a Gateway, click on the Gateway ID from the listing. This 
opens the Gateway Detail View with multiple tabs: 

Figure 20: Gateway Detail View 

4.4.1 Detail Tab 
Displays the following information: 

• Name
• Gateway ID
• Online/Offline Status
• Firmware Version
• Number of Connected Sensors
• Location
• Last Seen Timestamp
• Real-time CPU and RAM usage

4.4.2 Sensor Tab 
Allows you to: 

• View sensors currently connected to the Gateway
• Add/delete sensors
• Click on a Sensor ID to view sensor details (see Section 5)
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Figure 21: Attached Sensors 

4.4.3 Diagnostics Tab 
Monitor the health and performance of the Gateway over time: 

CPU and RAM Usage Graph 
• Toggle between predefined time ranges: 1 Day, 3 Days, 1 Week
• Alternatively, use the custom date range picker

Figure 22: Ram and CPU Chart 

Received Packets Statistics Graph 

• Analyze network traffic patterns
• Toggle between predefined time ranges: 1 Day, 3 Days, 1 Week
• Alternatively, use the custom date range picker
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Figure 23: Packet Statistics 

4.4.4 Logs Tab 
View the Gateway's behaviour and operational history: 

• Last firmware update date with user details
• Event details including:

• Online/offline status changes
• Reboots
• Sensor assignments
• Location changes

Figure 24: Gateway Logs 
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5. Sensor Management

5.1 Adding a Sensor to the Dashboard
⚠️ Note: You can add up to 10 sensors to a single gateway. 

Log into the edgeRX Dashboard using your authorised credentials, then navigate to Sensor 
Summary to view all registered sensors in a paginated table. 

Figure 25: Sensor Summary 

Steps to Add a Sensor 

1. Go to Sensor > Add Sensor.

Figure 26: Add Sensor Modal 

2. Enter the required details:



27 

Field Description 

Sensor Name A custom name for the sensor 

Sensor ID The Sensor ID (found printed on the side of each sensor) 

Gateway Select the appropriate Gateway from the dropdown 

Location Assign the sensor to a mapped location 

3. Click "Add" to register the sensor into the system.

The new sensor will appear in the table and be available for monitoring and configuration. 

⚠️ Note: For physical sensor installation instructions, refer to the edgeRX Lynq Sensor User 
Manual. 

5.2 Managing Sensors 

5.2.1 Edit a Sensor 
1. Navigate to the sensor listing.
2. Click the "Edit" icon from the actions column.
3. Update the Sensor Name and/or Gateway details.
4. Click "Confirm" to save the edited changes.
5. Clicking "Cancel" will terminate the edit action.

Figure 27: Edit Sensor 
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5.2.2 Delete a Sensor 
1. Click the "Delete" icon from the actions column.
2. Click "Confirm" to delete the sensor.
3. Clicking "Cancel" will terminate the delete action.

Figure 28: Delete Sensor Modal 

The sensor will be removed from the table and no longer available for monitoring. 
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5.3 Sensor Table Features 
The Sensor table provides a searchable, paginated view of all Sensors. 

Figure 29: Sensor Table 

Feature Description 

Search Bar Locate sensors by Name or Sensor ID 

Rows per Page Adjust display (dropdown in right bottom corner) 

Column Settings Customize visible columns (Settings gear in top-right corner) 

Table Columns: 
• Sensor ID
• Sensor Name
• Sensor Type
• Linked Gateway
• Online/offline status
• Battery Life
• Linked Asset
• Last Seen Time
• Firmware version
• Delete and Edit actions



30 

5.4 Sensor Configuration 

5.4.1 Process Queue 
The "Process Queue" button (on the top panel) enables you to view current and pending OTA 
& Configuration updates to the sensors. 

Figure 30: Process Queue Modal 

5.4.2 Configure KPI Interval 
1. Select one Sensor from the listing screen.
2. Click the "Configure" button on the top panel.
3. Input your desired KPI Interval.
4. Click "Save" to apply changes.

Figure 31: Configure Sensor 



 

31 
 

 
Figure 32: Configuration Modal 

5.5 Sensor Detail View 
Click on a sensor from the listing to open its Sensor Detail View. This page includes 
configuration settings, performance metrics, and AI insights. 

 
Figure 33: Sensor Detail View 
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5.5.1 Overview Tab 
Displays the following information: 

Visual Sensor Placement 
• Shows where the sensor is mounted

Figure 34: Bind Sensor Visual Guide 

⚠️ Note: Installation diagram will only show up after binding sensor to an asset. 

Connectivity and Signal Status 

Figure 35: Connectivity indicators 

Sensor Specifications: 
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• Output Data Rate (ODR)
• Full-Scale Range (FSR)
• KPI Interval
• Raw Data Interval
• Inference Interval
• Network

Figure 36: Sensor Specifications 

ML Information: 
• ML Model in use
• ML Type
• Class Label
• Score Threshold
• Class Alarm/Warning

Figure 37: Machine Learning Page 

Sensor Data: 
• Battery Voltage
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• RSSI
• Latency
• Skin Temperature
• VRMS (X, Y, Z)
• ML Classification

Figure 38: Sensor Data 

Asset Details: 
• Asset Type
• Asset Model
• Asset Name
• Location

Figure 39: Asset Details 

5.5.2 Diagnostics Tab 
Select a time range to view historical data including: 

• Battery Voltage
• RSSI (Signal Strength)
• Packet Statistics
• Latency
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Figure 40: Battery Voltage 

 
Figure 41: RSSI Graph 
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Figure 42: Packet Statistics 

Figure 43: Latency 
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5.5.3 Event Log Tab 
View a chronological record of system and model-related events, including: 

• Configuration changes
• Model deployments
• Sensor status changes
• Sensor resets
• Cluster/class label renaming
• Firmware updates
• Interval changes
• Changes in associations with assets, Gateways, or networks

Figure 44: Sensor Event 

5.5.4 Sensor History Tab 
View installation and removal records associated with the sensor or system. 

Figure 45: Sensor History 
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6. Asset Management

6.1 Adding Assets
⚠️ Note: To set up assets on the edgeRX dashboard, users must 

1. have created a department (see Section 3.5).
2. add an asset model in the AssetDB section (see Section 11.2.2) or add a model during

asset creation.

Log into the edgeRX Dashboard using your authorised credentials, then navigate to Assets 
Page to view all registered assets in a searchable, paginated table. 

Figure 46: Asset Table 

Steps to Add a New Asset 

1. Go to Assets > Add Asset.

Figure 47: Add Asset Model 

2. Enter the required details:
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Field Description 

Asset Name Custom name for identification 

Department Select from pre-selected list 

Asset Type Select from predefined types 

Criticality Select criticality level (High, Medium, Low) 

Asset Model Choose an existing model or create a new one 

Image Upload an image of the asset 

Facility Assign the asset to a mapped facility or zone 

Figure 48: Creating New Asset Model 

3. Click "Add" to register the asset into the system.

The new asset will appear in the table and be available for monitoring and configuration. 
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Figure 49: Asset Table 

6.2 Asset Table Features 
Feature Description 

Search Bar Locate assets by name, ID, or keyword 

Column Settings Show or hide specific fields 

Rows per Page Adjust display (dropdown in right bottom) 

Table Columns: 
• Asset Name
• Asset Type
• Linked/Associated Sensor(s)
• Status
• Last Updated Time
• Sensor Values
• Criticality (High, Medium, Low)
• Location
• Actions

6.3 Managing Assets 

6.3.1 Delete an Asset 
1. Click the "Delete" icon from the Actions column.
2. Click "Delete" in the modal that appears to confirm.
3. Clicking "Cancel" will cancel the delete action.

Figure 50: Delete Asset Model 

Upon confirmation, the asset will be removed from the system. 



41 

6.4 Binding Sensors to Assets 
To bind a sensor to an asset: 

1. Click on an Asset Name to open the Asset Detail View.

Figure 51: Asset Details 

2. Click the "Bind Sensor" button on the top right corner.
3. Enter the following details in the modal:

Field Description 

Sensor Type Type of sensor 

Sensor ID Select from available sensors 

Mounting Position Physical mounting location on the asset 

Orientation Sensor orientation (X, Y, Z axis) 
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Figure 52: Bind Sensor 

4. Click "Add" to bind the sensor to the asset.

Unbinding a Sensor 
1. Click on the Sensor ID of the sensor bound to that asset.
2. You will be redirected to the Sensors page.
3. Click the "Unbind" button on the top right corner.
4. Click "Confirm" to unbind.
5. Clicking "Cancel" terminates the action.

Figure 53: Unbind sensor 
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6.5 Asset Location Management 
To update the asset location: 

1. Click the "View Map" button to open the interactive map.

Figure 54: Asset Detail View Map 

2. Click the "Edit" icon next to Asset Location.
3. Drag and drop the asset pin to the correct position or select a predefined zone from the

dropdown list.

Figure 55: Asset Detail Edit Location 

4. Click "Save" to update the location.



44 

6.6 Asset Detail View 
Click on any asset from the listing to open its Asset Detail View. This page includes 
configuration settings, sensor assignments, and performance metrics. 

Figure 56: Asset Detail View 

6.6.1 Overview Tab 
Displays: 

• Asset Specifications
• Linked Sensor Information

Figure 57: Asset Detail Linked Sensors 

• Threshold Settings
• Location (View Map)
• Model Details
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6.6.2 Status Tab 
Displays: 

• Sensor trend data for vibration and temperature over time
• Visual indicators for anomalies and performance degradation

Figure 58: Asset Status Trend 

6.6.3 Event Tab 
Provides: 

• A chronological record of sensor and asset-related actions

Figure 59: Asset Detail Event 
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6.6.4 Asset Logs Tab 
Shows: 

• Installation and removal records
• Historical changes such as binding, unbinding, and coordinate updates

Figure 60: Asset Detail Logs 
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7. Machine Learning in edgeRX

7.1 ML Information Overview
The edgeRX platform leverages Edge AI to process data locally at the source. Machine 
Learning models analyze sensor data to detect anomalies and classify asset conditions in 
real-time. 

ML Information is displayed in the Sensor Detail View > Overview Tab (see Section 5.5.1). 

Figure 61: Sensor Machine Learning 

7.2 ML Model Types 
The edgeRX system supports various ML model types optimized for different asset monitoring 
scenarios. The specific model type deployed to each sensor depends on: 

• Asset type
• Monitoring requirements
• Historical performance data

7.3 Class Labels and Score Thresholds 
Class Labels 

Class labels represent different operational states of monitored assets, such as: 
• Normal Operation
• Degradation
• Fault Conditions
• Specific Failure Modes
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Score Thresholds 

Score thresholds determine when alerts are triggered: 

Threshold Type Description 

Warning Indicates potential degradation; requires monitoring 

Alarm Indicates critical condition; requires immediate attention 

 

Administrators can configure these thresholds in the ML Information section of each sensor. 
Notifications will not be sent if the scores fall under the threshold. 
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8. Viewing AI Inference Results

8.1 ML Insights Tab
The Machine Learning (ML) Insights tab enables you to view AI-based classifications and 
anomaly scores of the sensor, allowing you to assess the operational status of the asset and 
detect abnormal conditions in real-time. 

To access: Navigate to Sensor Detail View > ML Insights Tab. 

Figure 62: Sensor ML Class 

8.2 ML Inference Tab 
The ML Inference tab displays: 

• Inference results
• Class probabilities
• Real-time Anomaly scores

8.3 Start/Stop Live Inference 
Starting Live Inference 

1. Click "Start Live Inference".
2. Click "Confirm" to start collecting data in real-time.
3. Clicking "Cancel" will stop the live inference action.



50 

Figure 63: ML Live Inference Confirmation 

Stopping Live Inference 

Clicking "Stop Live Inference" before the predefined 10-minute timer ends will terminate the 
action and stop collecting live inference data. 

Viewing Real-Time Data 

The user can view: 
• Real-Time Anomaly scores
• Real-Time Anomaly Trend Chart of most recent 3 hours

Figure 64: Sensor ML Live Inference
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Figure 65: ML Real Time Chart 
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8.4 Historical Trends Analysis 
The Historical Trends tab displays trend analysis of the sensors. Users can see: 

• Median Score
• Anomaly Rate
• Max Anomaly Score

Figure 66: ML Historical Trends 

Time Range Selection 

Toggle between predefined time ranges: 
• 3 hours
• 8 hours
• 24 hours

Alternatively, use the date range picker to observe data in: 
• Anomaly Score Trend charts
• Class Probability Trends charts
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9. Data & Monitoring

9.1 Data Records
Navigate to Sensor Detail View > Data Record Tab to view performance trends and raw 
signal values. 

Figure 67: Sensor Data Records 

9.1.1 KPI Trend 
The KPI Trend tab includes two sub-tabs: 

Figure 68: Sensor KPI Trend 

ISO/Temp Sub-tab 

View: 
• Velocity RMS
• Rotating Speed
• Skin Temperature
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Acceleration Sub-tab 

View: 
• Acceleration Peak
• Acceleration RMS
• Crest Factor

Figure 69: Sensor Acceleration Chart 

Time Range Selection: 

• Toggle between 1 Week, 1 Month, 3 Months
• Alternatively, use the custom date picker

9.1.2 Raw Data 
The Raw Data tab includes two sub-tabs: Velocity and Acceleration. 

Figure 70: Sensor Raw Data 

Use the "View Baseline" button to show only records marked as baselines. 
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Figure 71: Sensor View Baseline 

Velocity Sub-tab 
View: 

• Velocity Chart
• Data table containing velocity details
• Velocity Spectrum Chart
• Peak Frequencies
• Harmonic Frequencies

Figure 72: Sensor Raw Data Velocity 
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Figure 73: Sensor Raw Data Velocity Spectrum 

 
Figure 74: Sensor Raw Data Peak and Harmonic Frequencies 

Acceleration Sub-tab 

View: 
• Acceleration Chart 
• Data table with Acceleration details 
• Acceleration Envelope Spectrum Chart 
• Peak Frequencies 
• Envelope Analysis results chart 
• Bearing Frequencies 
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Figure 75: Sensor Raw Data Acceleration 

Figure 76: Sensor Raw Data Acceleration Spectrum 
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Figure 77: Sensor Raw Data Envelop Analysis 

Figure 78: Sensor Raw Data Bearing Frequencies 
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9.1.3 Exporting Data 
Each chart includes an "Export" button to download data in CSV format. 

To export: 
1. Navigate to the desired chart (KPI Trend or Raw Data).
2. Click the "Export" button.
3. The data will be downloaded as a CSV file.

Figure 79: Graph Export Button 

9.2 ISO-Based Results 
ISO standards provide vibration thresholds for machinery condition monitoring. 

9.2.1 Understanding ISO Standards 
ISO vibration standards define acceptable vibration levels for rotating machinery based on: 

• Machine type
• Operating speed
• Mounting configuration

9.2.2 Viewing ISO Results 
ISO-based results are displayed in the KPI Trend > ISO/Temp sub-tab (see Section 9.1.1). 

The system compares measured vibration levels against configured ISO thresholds to 
determine asset health status 

9.2.3 Configuring ISO Standards 
For information on configuring ISO standards and thresholds, see Section 11.4. 
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9.3 Live View 
Navigate to Sensor Detail View > Live View Tab to monitor real-time acceleration waveforms 
across vertical, axial, and horizontal axes. Connection status is displayed in real time. 

Figure 80: Sensor Live View 

Adding Charts 

To add a new chart: 
1. Click "Add Chart".
2. Configure chart parameters:

Parameter Description 

Chart type Select visualization type 

Band pass filter Configure frequency filtering 

Frame Size Set data frame size 

FFT window type Select FFT window function 

Number of average Set averaging samples 
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Figure 81: Live View Add Chart 

3. Click "Confirm" to add the chart.
4. Clicking "Cancel" will terminate the action and the chart will not be added.

⚠️ Note: Multiple charts can be added for comparative analysis. 
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10. Notifications & Alerts

10.1 Notification Types
Log into the edgeRX Dashboard using your authorised credentials, then navigate to 
Notifications page. 

Figure 82: Notifications Tab 

The Notifications page has two tabs: 

10.1.1 Asset Tab 
View the list of alarm, warning, and ML notifications from assets. 

Search Capabilities: 
• Source
• Sensor
• Event

10.1.2 Device Tab 
View the list of notifications from Sensors & Gateways regarding offline/online status. 

Search Capabilities: 
• Device ID
• Event
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Figure 83: Notifications Tab Device 

10.2 Managing Notifications 

10.2.1 Acknowledge a Notification 
1. Click the "Acknowledge" (handshake) icon.
2. Add a comment in the field provided (optional).
3. Click "Confirm" to acknowledge the notification.
4. Clicking "Cancel" terminates the action.

Figure 84: Acknowledge Icon 
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Figure 85: Acknowledging Alarm Modal 

10.2.2 Delete a Notification 
1. Click the "Delete" (trash) icon.
2. Click "Confirm" to delete the notification.
3. Clicking "Cancel" will stop the action and the notification will not be deleted.

Figure 86: Delete Icon 

Figure 87: Deleting Alert Modal 

10.2.3 Bulk Actions 
To acknowledge or delete notifications in bulk: 
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1. Select multiple notifications using the checkboxes.
2. Click the "Acknowledge" or "Delete" icons on the top right.
3. The count of selected notifications is shown as badges on the icons.

Figure 88: Batch Selection 

10.3 Notification Filters 
Notifications can be toggled between the following filters: 

• All – Show all notifications
• Alarm – Show only alarm notifications
• Warning – Show only warning notifications

Figure 89: Filter Selection 

10.4 Email & Mobile Push Notifications 
To receive notifications via email or mobile push: 

1. Click the "Manage Notifications" button.
2. Enable the desired toggles:

• Asset Alarm
• Asset Warning
• Device Offline
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Figure 90: Manage Notifications Entry Point 

Figure 91: Manage Notifications Modal 

Notifications will be sent to your registered email address and/or mobile device. 
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10.5 Setting Warning/Alarm Thresholds 
The "Set Notification" button allows users to set Warning and Alarm Thresholds for 
parameters of Sensors and Gateways. 

To configure thresholds: 
1. Click "Set Notification".
2. Select the device (Sensor or Gateway).
3. Configure the threshold values for relevant parameters.
4. Click "Save" to apply changes.

Figure 92: Set Notifications Entry Point 

Figure 93: Set Notifications Modal 
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10.6 Notification Table Features 
The Notifications table provides a searchable, paginated view of all notifications. 

Feature Description 

Search Bar Find notifications from Assets and Devices 

Rows per Page Adjust display (dropdown in bottom right corner) 

Column Settings Customize visible columns (Gear option on top right corner) 

Figure 94: Notifications Column Display 
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11. Configuring Settings
Log into the edgeRX Dashboard using your authorised credentials, then navigate to Settings to 
manage system-wide configurations including location hierarchy, asset specifications, fault 
databases, and ISO standards. 

Figure 95: Menu Bar 

11.1 Location Hierarchy 
Navigate to Settings > Manage Locations to view the hierarchical layout of Sites, Buildings, 
Floors, and Rooms. 

Figure 96: Manage Locations 

Hierarchy Structure: 

Site → Building → Floor → Room  

Boxes labelled with names will be visible on the screen. 

11.1.1 Adding a Site 
1. Click "Add" to create a new site.
2. Enter the following details:
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Field Description 

Site Name Name of the site 

Site Map Upload a site map image 

Figure 97: Add Site 
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Figure 98: Add Site Modal 

3. Click on 2 separate points to mark A and B
4. Enter the Actual Distance in meters.
5. Click "Save" to add the Site.

11.1.2 Managing Existing Locations 
Use the following controls to manage Sites, Buildings, Floors, and Rooms: 

Control Action 

Edit Click the "Edit" icon, update Name/Image/Actual Distance, click "Save" 

Delete Click the "Delete" icon and confirm the action 

Preview Click the "Preview" (eye) icon to view location on map 

Reorder Use "Up" and "Down" arrow controls 

⚠️ Note: These controls behave the same for Sites, Buildings, Floors, and Rooms. 
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Figure 99: Site Controls 

Figure 100: Edit Site Map 

Figure 101: Delete Site Modal 
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Figure 102: Preview Site 

11.1.3 Adding a Building 
1. Click "Add" button in the Buildings box. 
2. Enter the Building Name. 
3. Click on the image to generate at least 3 points. 
4. Click "Save" to add the Building. 

 
Figure 103: Add Building Modal 
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11.1.4 Adding a Floor 
1. Click "Add" button in the Floors box.
2. Enter the Floor Name.
3. Upload a Site Map.
4. Click "Save" to add a Floor.
5. Click on 2 separate points to mark A and B
6. Enter the Actual Distance in meters.

Figure 104: Add Floor Modal 

11.1.5 Adding a Room 
1. Click "Add" button in the Rooms box.
2. Enter Room Name and Room Color.
3. Click on the image to generate at least 3 points.
4. Click "Save" to add a Room.
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Figure 105: Add Room Modal 

11.1.6 Map Toolbar 
Use the Map Toolbar to interactively manage the layout: 

• Zoom – Zoom in/out of the map
• Reset – Reset map to default view
• Scaling (AB points) – Set scale reference points
• Origin adjustment – Adjust map origin
• Layout reset – Reset layout to default

11.2 Manage Asset DB / Asset Types 
Navigate to Settings > Manage Asset DB > Asset type to view and configure asset types. 

Figure 106: Manage Asset Type 

11.2.1 Adding a Custom Field 
1. Click the "+ Add Custom Field" button.
2. Enter the following details:
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Field Description 

Field Name Name of the custom field 

Field Type Data type (text, number, etc.) 

Unit Unit of measurement (if applicable) 

Figure 107: Custom Field 

3. Click "Add" to create the custom field.

11.2.2 Adding an Asset Model 
1. Click "Add Model" to input specifications for a selected asset type.
2. Enter the following:

Field Description 

Asset Model Name Name of the model 

Rotate Speed (RPM) Rotational speed in RPM 

DE Bearing Drive-end bearing specification 

Num of Impeller Number of impellers 

Voltage (V) Operating voltage 

Current (A) Operating current 
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Figure 108: Asset DB Asset Type 

 
Figure 109: Add Asset Modal 

3. Click "Confirm" to add the Model. 

11.2.3 Managing Asset Models 
You can view all models under each type and use the Edit or Delete links to manage them. 
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Sensor location values can also be added, edited, or deleted dynamically to define exact 
placement points. 

11.3 Bearing DB 
Navigate to Settings > Bearing DB to view, add, edit, or delete fault entries. 

Figure 110: Asset DB Bearing 

11.3.1 Adding Bearing Fault Data 
1. Click "Add" to input new bearing fault frequency.
2. Enter the following:

Field Description 

Bearing type Type/model of bearing 

Number of balls Number of rolling elements 

FTF_60RPM Fundamental Train Frequency at 60 RPM 

BSF_60RPM Ball Spin Frequency at 60 RPM 

BPFO_60RPM Ball Pass Frequency Outer race at 60 RPM 

BPFI_60RPM Ball Pass Frequency Inner race at 60 RPM 
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Figure 111: Add Bearing Modal 

3. Click "Save" to add the bearing fault data. 

11.3.2 Editing Bearing Fault Data 
1. Click the "Edit" icon from the actions column. 
2. Update the fault frequency values. 
3. Click "Confirm" to save changes. 
4. Clicking "Cancel" will terminate the edit action. 

11.3.3 Deleting Bearing Fault Data 
1. Click the "Delete" icon from the actions column. 
2. Click "Confirm" to delete the bearing. 
3. Clicking "Cancel" will terminate the delete action. 

11.3.4 Bulk Upload Bearing Faults 
To bulk upload bearing faults: 

1. Click the "Import" button. 
2. Download the template file. 
3. Complete the template offline with your bearing data. 
4. Upload the completed file back into the system. 
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Figure 112: Bearing List Upload 

11.4 ISO Standards 
Navigate to Settings > ISO Standards to view and configure vibration thresholds. 

Figure 113: ISO Standards 
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11.4.1 Adding an ISO Standard 
1. Click "Add" to add an ISO standard. 
2. Enter the following: 

 
Field Description 

ISO Standard ISO standard name/number 

Description Description of the standard 

Warning Threshold Vibration level that triggers warning 

Alarm Threshold Vibration level that triggers alarm 

 

 
Figure 114: ISO Standard Modal 

3. Click "Save" to add the ISO standard. 

11.4.2 Editing an ISO Standard 
1. Click the "Edit" icon from the actions column. 
2. Update the standard details. 
3. Click "Confirm" to save the edited changes. 
4. Clicking "Cancel" will terminate the edit action. 

11.4.3 Deleting an ISO Standard 
1. Click the "Delete" icon from the actions column. 
2. Click "Confirm" to delete the ISO standard. 
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11.5 Fault Diagnosis 
Navigate to Settings > Manage Asset DB > Asset Type > Fault Diagnosis to view a list of 
predefined fault types for this asset model. 

Figure 115: Fault Diagnosis 

This section displays the fault diagnosis categories configured in the system for asset 
condition monitoring. 
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12. Troubleshooting
This section covers common dashboard-related issues. For hardware troubleshooting, refer to 
the respective hardware user manuals (see Section 1.2). 

12.1 Sensor Issues 

12.1.1 Sensor Appears Offline on Dashboard 
If a sensor shows as offline in the dashboard: 

1. Ensure sensor was turned on by checking the on/off switch found in the sensor.
2. Ensure that the sensor MAC ID was entered successfully when adding the sensor to

the dashboard.
3. Ensure that the sensor was successfully bound to the gateway and the asset.

Figure 116: Sensor Offline 

If the issue persists after these checks, contact your TDK SensEI representative for 
assistance. 

12.1.2 Sensor LED Indicators 
For information about sensor LED indicators and their meanings, please refer to the edgeRX 
Lynq Sensor User Manual (SE1111101G-01), Section "LED Status & Descriptions." 
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12.2 Gateway Issues 

12.2.1 Gateway Appears Offline on Dashboard 
If a gateway shows as offline in the dashboard: 

1. Ensure that gateway power supply was attached properly – Check all power
connections.

2. Ensure that gateway was added to a location successfully on the dashboard.

Figure 117: Gateway Offline 

If the issue persists after these checks, contact your TDK SensEI representative for 
assistance. 

12.2.2 Gateway LED Indicators 
For information about gateway LED indicators and their meanings, please refer to the edgeRX 
Gateway User Manual (SE5100204G-01), Section "LED Status & Descriptions." 

12.3 Dashboard Issues 

12.3.1 No Data Appearing on Dashboard 
If sensor data is not appearing on the dashboard: 

1. Verify that sensors are online (see Section 12.1.1).
2. Verify that gateways are online (see Section 12.2.1).
3. Check that sensors are properly bound to assets (see Section 6.4).
4. Refresh your browser page.

12.3.2 Widget Appears Inactive or Blank 
If widgets on the homepage dashboard appear inactive or blank: 

1. Confirm that your gateways and sensors are online.
2. Check your network connection.
3. Verify that you have proper permissions to view the data (see Section 3).
4. Try switching to a different location using the location selector (if available).
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12.4 Contacting Support 
If any issues persist after following the troubleshooting steps, please contact your local TDK 
SensEI representative.  

When contacting for support, please provide the following: 
• User account information
• Description of the issue
• Screenshots (if applicable)
• Steps taken to troubleshoot
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Appendix 

A. Glossary of Terms 

Term Definition 

Asset A piece of equipment or machinery being monitored by the edgeRX system 

edgeRX TDK SensEI's end-to-end platform for real-time equipment health monitoring 

Gateway Hardware device that collects sensor data and transmits it to the cloud 

KPI Key Performance Indicator – measurable values used to evaluate asset health 

ML Machine Learning – AI algorithms used to analyze sensor data 

MFA Multi-Factor Authentication – security feature requiring multiple verification methods 

Sensor Hardware device that collects vibration and temperature data from assets 

ISO International Organization for Standardization – defines vibration standards 

RSSI Received Signal Strength Indicator – measures wireless signal strength 

RPM Revolutions Per Minute – rotational speed measurement 

RMS Root Mean Square – statistical measure of vibration magnitude 

FFT Fast Fourier Transform – algorithm for frequency analysis 
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B. Related Documentation
For complete information about the edgeRX system, please refer to the following documents: 

Document Title Model Number Description 

edgeRX Gateway User 
Manual SE5100204G-01 

Hardware setup, installation, network configuration, 
LED indicators, physical troubleshooting 

edgeRX Lynq Sensor User 
Manual SE1111101G-01 

Hardware activation, physical installation, battery 
information, LED indicators, physical troubleshooting 

edgeRX Dashboard User 
Guide (this document) - Software navigation, monitoring, and configuration 

These documents can be obtained from your TDK SensEI representative. 




